Connection Problems with SL-9111

  • Dear EasySMX team,

    I have bought the SL-9111 controller (wired) and have connection problems.

    When I start the PC (with the controller connected) I don't get it switched to XInput or DirectInput (not even by pressing the Mode button for 5 seconds). The control lamps for XInput (lamps 1 & 2) or DirectInput (lamps 1 & 3 or 1-3) do not light up.
    This only works if I unplug the controller from the USB while the PC is running and then plug it in again. Then it is immediately on XInput (lamps 1 & 2 light up) and I can also switch to DirectInput (lamps 1 & 3 or 1-3 light up) with the mode button.
    The controller is recognized by the PC in the game controller properties of Windows 10 after the start, but since it is neither set to XInput nor DirectInput (there is also no lamp for the mode display) I cannot use the controller in any game. I have to remove the controller from the USB port and reinsert it EVERY TIME, otherwise I won't be able to go into XInput or DirectInput mode.
    I have never had this problem with other controllers and it does not seem to be due to me / my PC because the controller is recognized, but the mode cannot be changed.

    I hope you can help me with my problem and thank you in advance for your help.

  • I found the Problem:

    If the controller no longer receives power via USB, e.g. Because of the Advanced Configuration and Power Interface (ACPI) / ErP
    setting or switched off power supply, you have to pull the USB plug in and out every time so that it works again.
    You wrote in the FAQ about the controller you should press the mode button for 5 seconds if the controller is not recognized by Windows. (THAT DOES NOT WORK)
    If the controller has no more power on the usb connection the controller only works again when you pull it out of the USB port and put it back in again.

  • @Miler oh wow ­čś▓, i have sl-9111 which is my favorite controller and i never had that problem, it's true that if you restart your computer your m buttons settings have to be configured again. I used that controller 2 months and works normal on windows 10. I just can suggest that if you have more apparatus plugged in your pc, remove all of them and test it again.

    Other thought that i have is that your usb port it's absolutely broke because sounds like my first pc Problem connecting and expulsing every single thing that i connect on usb ports. And other suggest is try to use the controller on other pc or in android to be sure about if it's an problem of your controller or of your usb port. Try too remove the controller from your pc but into settings-hardware section (where appear your mouse, keyboard etc connected to your pc) there click on the controller and quit it and after unplug and plug it again to let it install again. And keep calm 

  • @Miler Aaah i already read the second part right now, dude if it's an windows setting that you have about usb ports power i don't why you have to say that it's an controller problem. Probably you have others with wireless dongle usb which works different than wired i don't know. Just adjust your pc settings or just use the controller when you want to play Cx

  • Your answer is not very helpful in this thread because you seem to have no idea or no experience or do not understand the problem.

    My USB connections are working and I don't know what Windows has to do with the power supply from the USB port when it is switched off.

    You have a different ACPI / ErP setting or no RGB lighting on your usb devices and therefore it will work for you "or" you will not notice the error.
    I also do not think that you have understood what the error is.
    All my other usb devices (mouse / keyboard / headset) work after a cold start, only the controller does not.
    Or it is recognized in the Windows game controller settings but not as an XInput (lamp 1 + 2) or DirectInput (lamp 1 + 3) controller but as a Thunderbot G30, but it does not work in games because it is neither active on XInput nor DirectInput is.
    I can also set it so that it works, i.e. that it is also in XInput mode after the start, but then I have permanent power on the usb ports even when the pc is switched off. i.e. my RGB of the headset / mouse / keyboard light up permanently even when the pc is off.

    And you call that normal?
    And resetting the M keys after every restart is also not good.
    it may be that you accept such errors but it is not normal.

  • @Miler probably no, but i tried to help as user to user because I'm NOT the support team where i suggest you send an email i just tried to help and as USER i have no why know everything :) i didn't created that controller to can reply all. So that's my suggestion, send an email there

  • that's nice of you too that you took the time and tried to help me. that's why I tried again to explain exactly what the problem is.

    i have already turned to the support but they are primarily responsible for sales / shop and could not help me.

    i like the controller too (apart from the technical problems).
    that's why I'm trying to find a solution.

    was not meant to be angry with me

  • @Miler did you tried to download it drivers too?:( Yesterday i used the sl-9111 as example for put the controller on update mode. Just holding the l3 joystick and connect to usb port it turns on update mode or like i called it, the police mode, because the lights become crazy. Let's try that thing i don't know 

  • There is no Driver for the SL-9111.

  • I installed the driver for the ESM-9110 as there are no drivers for the SL-9111.

    The driver is a Microsoft XBox One controller driver. I tried that with the I3 key. (looks great ­čśé) Unfortunately it didn't help.

    But if I keep the button pressed while the PC starts, the light show of the controller begins. Whenever the pc is booted up, I can use the mode button, as it is in the faq's. switch to xinput mode and the controller works (is recognized) without having to pull the usb plug in and out. the disadvantage is of course I have to keep the button pressed before starting the pc.
    Every time.

  • @Miler true there are no drivers for 9111 but the controller have update mode.... That's sad

  • Same problem with the controller!!

    There's no solution yet?

  • When USB is first plugged in, it operates normally and recognizes it as an Xbox360 Controller, but if it is restarted with it plugged into the USB port, it will recognize it as Thunderbot G30 and will not function normally.

    The fatal drawback of having to pull out the USB port and put it back on.

  • @Miler How? Which button do I have to press when I boot? I tried pressing any button, but it didn't work.

  • Administrator
    Staff member

    Hi´╝îThere may be a problem with the USB port of your computer, please try another computer to test. If it still doesn't solve your problem, please tell us know where did you buy it? Please also send me your order number to, we will help you.

    Have a nice day!

  • Have followed the instructions to a T, but the dongle is still not working.

    stumble guys

  • I hope you can help me with my problem

    Flappy Bird

  • I appreciate everything you have added to my knowledge base. Best Sms App For Android Wear 2023

  • Problems with SL-9111 resolved after passing Five Nights at Freddy's 4

Please login to reply this topic!