EasySMX ESM-9013 game controller discussion post

  • Hello,

    I've bought a Dual-Pack of the ESM-9013 and one of them worked just fine until recently, where I tried the second controller and noticed that they're not being recognized the same way. (One is recognized as Xbox Controller, the other as "PC USB CONTROLLER 1.07")

    Through the manual and searching through forum I figured that's a mode problem.
    I tried pressing the button for 5 seconds multiple times, but nothing changes or happens on the controller. Like I can hold it for 30 seconds solid and nothing happens, or just 5 for seconds and nothing happens either.

    On the controller, only the left-upper-LED is lit up, which according to this page https://www.easysmx.com/products/wireless-receiver-dongle-for-easysmx-esm-9013-controller means that it's in PS3 Mode.

    By searching on google I also found this forum post, where a similar problem is reported: https://www.easysmx.com/community/forum/topic/25604/esm-9101-in-strange-mode

    I've used the "ESM9013 Dongle Updater" from the last post in that topic, but it doesn't seem to work.
    The application is running, but nothing is detected when the Dongle inserted in my laptop.

    I've also installed the driver from https://drive.google.com/drive/folders/1XPRtFlC6Cba0SVDwTgCkZiXGpg9M-njF but nothing really changes.


    How can I fix my controllers now? Because I somehow managed to also get the second controller into this mode.
    I really would like for the controller to be recognized as an XBOX Controller, because it works just better for some of my games.

    I feel like I really tried everything, at least from what I could find on this forum and on the internet.

    Please help me, kind regards


  • @N R if you have upper drivers version and you can't update, just hold "shift" for can update the drivers. Another guy had that problem and apparently was because he had a lot of controllers in using in his pc and his problem has been solved just resetting the computer. Try that second option and if it doesn't work try update the drivers like i said holding shift :) have a great day

  • Hello @Jink 999
    I don't know what you mean with "holding shift", when I start the dongle updater application and hold shift, nothing changes.

    And what do you mean by resetting the computer?

    Generally my problem is that the controller is stuck in that mode and no other input mode is possible to be activated.

  • @N R @N R with holding shift i mean with the updating drivers program and it´s an keyboard keycap, and with reset the pc i mean turn it off and turn it on again :v

  • Administrator
    Hello friend,
    Maybe the order is not correct, open the program first, and insert the receiver.
    When appealing this window means you can get updated.
    9013 dongle update
    Here is also a post for reference. Although it's not the same model but the steps are similar:

  • Hello @Xayah 

    I have linked that post for reference in my original post above and it doesn't really help, because the program never shows device information.
    (It doesn't matter in what order and if turning my pc off & on again would solve the problem, it would have happened long ago)
    I even tried booting in windows safe mode to check for driver issues, but the program does nothing, except the below.

    This is what it looks like in my device manager (when view is changed to 'Container')

    The program I use is from the last post in the linked topic, where you replied it is the ESM 9013 Dongle updater.

    Here is a photo of the controller and the mode it is in:

    I've really tried a lot of things at this point and I just want to know how I can get the controller out of this mode, so I can use it as XINPUT (XBox 360) again.
    Holding the button home button does nothing for me, I've tried for 5 seconds, 10 seconds, and longer as well.
    I also tried holding the button without the dongle or holding it from the beginning where I turn the controller on.

    My problem is, that the controller is not very usable in this mode and also behaves weird when used in Steam Big Picture...

    I just want to mention, I'm technically capable to provide you with information if you need it or even give you a Trace-File of USBPcap, but you gotta point me in the right direction, because I don't know how this firmware really works.
    Maybe it's due to it being the wrong application, because in the window-title it says ESM_9103 instead of ESM_9013 but that could be a programming fluke.
    Here's the link that I downloaded from that post:

    Kind regards


  • @N R Hi bro, maybe you can record a video showing the whole process of the downloading so they may help to pin down the problem.


  • I'm suffering with the same exact issue. I don't have a controller and I absolutely HATE using mouse and keyboard on pc games, and I have 2 controllers that are doing the exact same thing you are describing. I'm literally going fucking insane without a working controller and I need a solution because I already bought 2 and both are doing the exact same fucking thing. 

  • Guys I have a 100% working fix, just follow these steps :

    1. Pick up your EasySMX controller

    2. Throw it in the trash where it belongs

    3. Go to the mall

    4. Get a proper Xbox ONE controller

    5. Easy fix !!


  • @N R Have you solved this problem?

  • @Fifi LaRafale I followed your instructions. Now my EasySMX is in the trash and doesn't work again!

  • Hi there, just sharing my experience since I have this issue once in a while and so far I've always been able to fix it by doing these exact steps in this exact order:

    1 - download xb1usb.11059.0.140526 driver for the joypad. Open the file, if it says "install" then go ahead and check if that solves your issue. If not, or "install" is greyed out:
    2 - disconnect dongle then turn joypad off
    3 - Restart Windows
    4 - Open xb1usb.11059.0.140526 and select "remove"
    5 - Restart windows again
    6 - Open xb1usb.11059.0.140526 and select "install"
    7 - Connect dongle
    8 - Turn joypad on

    Once I do this, the lights on the pad are 2 again and works as Xbox controller. Hope you guys are able to solve your problem with this.

  • @N R Hello,
    One out of 2 controllers is stuck in this mode (upper right lit), no button press will do anything.

    How did you solve it?
    Thank you!

  • Hi everyone, i got an error while updating the dongle of my Easysmx 9013 and first it detect as ''updater'' now the pc does not detecting the dongle and dongle's light is also on much less than usual (almost no lighting). Please can anyone help me?

  • L'ESM-9013 peut-il le rendre plus rapide ? 


Please login to reply this topic!