ESM-9013 does not work in Unity (XInput is not enabled)


  • Hello!
    My gamepad ESM-9013 is stuck on Switch mode. I found a lot of queries with the same problems here. And there are no concrete proposals anywhere on how to solve this problem.

    The problem manifests itself as follows. On windows 10, you connect the gamepad and it immediately switches to Switch mode. The upper left LED is on. A long press on the Home button does not allow you to switch the mode. The gamepad is not available in Unity.

    How to solve this problem? Or will you have to give up your gamepads?



  • Administrator
    Administrator
    Administrator
    Staff member

    @Sukhrob Khusamov Please check first if your dongle is normal. Plug the dongle into the computer, if the controller only has the LED on, then the dongle is broken.If your dongle is normal, please connect the switch with OTG adapter


  • @EasySMX

    My dongle is fine. I have two ESM-9013 controllers and both work fine.

    1) Controllers work if you connect them to the Gamepad API of modern browsers. For example, in browser games, the gamepad works.

    2) It also works in some PC Desktop games.

    I have a problem with Unity:

    1) During the development of the game in Unity, the controller does not work. Because it is constantly in Switch mode. And you need the XInput mode

    2) If you check the controller in the browser, you can see that it is enabled as Switch Pro. It's just that the browser works with all kinds of controllers, and Unity only XInput

    3) As I already wrote - long pressing the Home button does not switch the gamepad to other modes. It is stuck tightly in Switch mode.

    And it's not just me. You look at your forum. Many have such a problem. I can throw off all the links I found. And you don't react to this problem in any way.


  • Administrator
    Administrator
    Administrator
    Staff member

    @Sukhrob Khusamov This involves the compatibility of the controller development scheme. In the Unity program, auxiliary plug-ins are required to be compatible with the controller. please try to use the InControl plug-in.


Please login to reply this topic!